[solved] ARCHLabs+3 -pamac-updater authentication failed

Please report any bugs you find in AL here.

One bug per thread please.

Moderator: Founder

[solved] ARCHLabs+3 -pamac-updater authentication failed

PostPosted by erikdubois » Wed Mar 08, 2017 2:32 am

Environment - VirtualBox
VirtualBox version - 5.1.14 r112924
ISO version - ARCHLabs+3.iso

At reboot there are already a few applications that need an update. Trying to update results in an message
authentication fails

reason : policy kit

solution :
autostart file add this line
other line has to go - just fixed this in the previous version - not yet mentioned here

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1

THIS SHOULD BE CONFIRMED BY OTHERS
Living to learn, learning to live.
Linux fits well in my life's motto.
More info on http://erikdubois.be
Archlabs support articles are on https://goo.gl/AaYI0b
Archlabs support youtube channel is on https://goo.gl/Lovquv
User avatar
erikdubois
Site Admin
Site Admin
 
Posts: 333
Joined: Sun Mar 05, 2017 5:42 am
Location: Belgium

Re: ARCHLabs+3 -pamac-updater authentication failed

PostPosted by postmasterdclxvi » Wed Mar 08, 2017 5:22 am

Bug confirmed. Correcting the line in autostart file fixes the Authentication Failure message in pamac.
In the depths of a mind insane,
Fantasy & reality are the same.
User avatar
postmasterdclxvi
Moderator
Moderator
 
Posts: 25
Joined: Fri Mar 03, 2017 7:25 am
Running Release: 4+

Re: ARCHLabs+3 -pamac-updater authentication failed

PostPosted by knob » Wed Mar 08, 2017 3:07 pm

Solution confirmed
knob
 
Posts: 1
Joined: Sat Feb 25, 2017 10:37 pm

Re: ARCHLabs+3 -pamac-updater authentication failed

PostPosted by Dobbie03 » Wed Mar 08, 2017 4:35 pm

I was just about to add this to the tip forum.
I like my Metal like my coffee.......black
User avatar
Dobbie03
Founder
Founder
 
Posts: 549
Joined: Sat Feb 18, 2017 2:51 pm
Location: New Zealand
Running Release: DobbieBang

Re: ARCHLabs+3 -pamac-updater authentication failed

PostPosted by loop » Sat Mar 18, 2017 4:01 am

Hi! how i can fix it???
loop
 
Posts: 5
Joined: Wed Mar 15, 2017 11:18 pm

Re: ARCHLabs+3 -pamac-updater authentication failed

PostPosted by Dobbie03 » Sat Mar 18, 2017 5:41 am

loop wrote:Hi! how i can fix it???


Re-read the first post in this thread.
I like my Metal like my coffee.......black
User avatar
Dobbie03
Founder
Founder
 
Posts: 549
Joined: Sat Feb 18, 2017 2:51 pm
Location: New Zealand
Running Release: DobbieBang

Re: ARCHLabs+3 -pamac-updater authentication failed

PostPosted by loop » Sat Mar 18, 2017 6:12 am

It means nothing to me
loop
 
Posts: 5
Joined: Wed Mar 15, 2017 11:18 pm

Re: ARCHLabs+3 -pamac-updater authentication failed

PostPosted by Dobbie03 » Sat Mar 18, 2017 7:10 am

In your ~/.config/openbox/autostart look for:

Code: Select all
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &


and replace it with:

Code: Select all
## GNOME PolicyKit authentication
#/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &



Restart your computer.
I like my Metal like my coffee.......black
User avatar
Dobbie03
Founder
Founder
 
Posts: 549
Joined: Sat Feb 18, 2017 2:51 pm
Location: New Zealand
Running Release: DobbieBang

Re: ARCHLabs+3 -pamac-updater authentication failed

PostPosted by loop » Sat Mar 18, 2017 8:37 am

Thanks a lot!!!
Best regards!
loop
 
Posts: 5
Joined: Wed Mar 15, 2017 11:18 pm


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 0 guests