[Solved] Archlabs doesnt show me any wifi networks

For general ARCHLabs and Arch issues.
Please make a serious attempt to search for your issue before posting here.
We can't offer help if you have the Testing Repos enabled.

Moderator: Founder

[Solved] Archlabs doesnt show me any wifi networks

PostPosted by Sharky » Sun Jul 30, 2017 6:25 am

Hi,can someone help me please, how to setup wifi.Archlabs doesnt show me any networks.
Sharky
 
Posts: 4
Joined: Sun Jul 30, 2017 6:14 am
Location: Germany
Running Release: R2D2

Re: Archlabs doesnt show me any wifi networks

PostPosted by Dobbie03 » Sun Jul 30, 2017 8:55 am

Can you post the output of lspci -k
I like my Metal like my coffee.......black
User avatar
Dobbie03
Founder
Founder
 
Posts: 552
Joined: Sat Feb 18, 2017 2:51 pm
Location: New Zealand
Running Release: DobbieBang

Re: Archlabs doesnt show me any wifi networks

PostPosted by alga » Sun Jul 30, 2017 2:42 pm

As I know the networks will only show up when there is any network available. If, for example, the router(sharing device) isn't turned on or network cable not connected, the networks won't show up in the menu, otherwise they will appear automatically.
alga
 
Posts: 11
Joined: Sun Jul 30, 2017 1:14 am
Running Release: R2D2

Re: Archlabs doesnt show me any wifi networks

PostPosted by Sharky » Sun Jul 30, 2017 2:45 pm

Code: Select all
sharky@Acer-Aspire-5742G
                          ------------------------
                          OS: ArchLabs v5.0.0
                          Kernel: 4.12.3-1-ARCH
                          Memory: 1068MiB / 3820MiB
                          Uptime: 3 hours, 28 mins
                          Packages: 1330
                          Shell: bash 4.4.12
                          Resolution: 1366x768
                          DE: Xfce
                          WM: Openbox
                          Theme: Arc-Havelock-Dark
                          Icons: Sardi-Flexible-Mandy
                          Terminal: xfce4-terminal
                          CPU: Intel i5 M 460 (4) @ 2.534GHz
                          GPU: NVIDIA GeForce GT 420M




Code: Select all
[sharky@Acer-Aspire-5742G ~]$  lspci -k
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
   Subsystem: Acer Incorporated [ALI] TravelMate 5742
   Kernel modules: intel_agp
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
   Kernel driver in use: pcieport
   Kernel modules: shpchp
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: mei_me
   Kernel modules: mei_me
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: ehci-pci
   Kernel modules: ehci_pci
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
   Kernel driver in use: pcieport
   Kernel modules: shpchp
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
   Kernel driver in use: pcieport
   Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: ehci-pci
   Kernel modules: ehci_pci
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation HM55 Chipset LPC Interface Controller (rev 05)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: lpc_ich
   Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: ahci
   Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: i801_smbus
   Kernel modules: i2c_i801
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: intel ips
   Kernel modules: intel_ips
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 420M] (rev a1)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: nvidia
   Kernel modules: nouveau, nvidia_drm, nvidia
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
   Subsystem: Acer Incorporated [ALI] Device 0487
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel
02:00.0 Ethernet controller: Broadcom Limited NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
   Subsystem: Acer Incorporated [ALI] Device 036d
   Kernel driver in use: tg3
   Kernel modules: tg3
03:00.0 Network controller: Broadcom Limited BCM43225 802.11b/g/n (rev 01)
   Subsystem: Foxconn International, Inc. T77H103.00 Wireless Half-size Mini PCIe Card
   Kernel modules: bcma
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
   Subsystem: Acer Incorporated [ALI] Device 0487
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
   Subsystem: Acer Incorporated [ALI] Device 0487
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
   Subsystem: Acer Incorporated [ALI] Device 0487
ff:02.1 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor QPI Physical 0 (rev 02)
   Subsystem: Acer Incorporated [ALI] Device 0487
ff:02.2 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor Reserved (rev 02)
   Subsystem: Acer Incorporated [ALI] Device 0487
ff:02.3 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor Reserved (rev 02)
   Subsystem: Acer Incorporated [ALI] Device 0487
[sharky@Acer-Aspire-5742G ~]$
Sharky
 
Posts: 4
Joined: Sun Jul 30, 2017 6:14 am
Location: Germany
Running Release: R2D2

Re: Archlabs doesnt show me any wifi networks

PostPosted by Sharky » Sun Jul 30, 2017 3:02 pm

Thank you for your help ! :D
Sharky
 
Posts: 4
Joined: Sun Jul 30, 2017 6:14 am
Location: Germany
Running Release: R2D2

Re: Archlabs doesnt show me any wifi networks

PostPosted by Dobbie03 » Sun Jul 30, 2017 3:17 pm

You might need some drivers, check the b43 section
https://wiki.archlinux.org/index.php/br ... reless#b43
I like my Metal like my coffee.......black
User avatar
Dobbie03
Founder
Founder
 
Posts: 552
Joined: Sat Feb 18, 2017 2:51 pm
Location: New Zealand
Running Release: DobbieBang

Re: Archlabs doesnt show me any wifi networks

PostPosted by Sharky » Sun Jul 30, 2017 5:42 pm

I had to reinstall broadcom wl and now its working ,thanks for your help
Sharky
 
Posts: 4
Joined: Sun Jul 30, 2017 6:14 am
Location: Germany
Running Release: R2D2

Re: Archlabs doesnt show me any wifi networks

PostPosted by Dobbie03 » Sun Jul 30, 2017 6:13 pm

Good work, well done.
I like my Metal like my coffee.......black
User avatar
Dobbie03
Founder
Founder
 
Posts: 552
Joined: Sat Feb 18, 2017 2:51 pm
Location: New Zealand
Running Release: DobbieBang


Return to Basic Help and Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron