(open) Package Building on Archlabs.

Post your suggestions and improvements for future releases of ARCHLabs.

Moderator: Founder

(open) Package Building on Archlabs.

PostPosted by dros » Mon Jul 10, 2017 6:44 am

Hello, I have installed R2-D2 and it's really great. I love the polish and the amount of attention to detail that has gone into this project!
One thing I noticed is that the Archlabs packages are not being built in a chroot. Building in a clean chroot checks for sanity as well as checking that all dependencies are in place.
For example, the buildinfo from your repo of yaourt :
Code: Select all
builddir = /home/ajjames31/Builds/yaourt
pkgbuild_sha256sum = a58ed2f638d1e42d0d1399571687250d6fa0a389ac4a589b45ba32f4c76c59f7
buildenv = !distcc
buildenv = color
buildenv = !ccache
buildenv = check
buildenv = !sign
options = strip
options = docs
options = !libtool
options = !staticlibs
options = emptydirs
options = zipman
options = purge
options = !optipng
options = !upx
options = !debug
installed = acl-2.2.52-2
installed = adwaita-icon-theme-3.20-2
installed = alsa-lib-1.1.1-1
installed = alsa-plugins-1.1.1-1
installed = alsa-utils-1.1.1-1
installed = archlinux-keyring-20160402-1
installed = archlinux-wallpaper-1.4-2
installed = aspell-0.60.6.1-5
installed = at-spi2-atk-2.20.1-2
installed = at-spi2-core-2.20.2-1
installed = atk-2.20.0-1
installed = atkmm-2.24.2-2
installed = attr-2.4.47-1
installed = autoconf-2.69-3
installed = automake-1.15-1
installed = avahi-0.6.32-2
installed = bash-4.3.042-5
installed = bash-completion-2.3-4
installed = binutils-2.26-4
installed = bison-3.0.4-2
installed = blas-3.6.1-1
installed = boost-1.60.0-5
installed = boost-libs-1.60.0-5
installed = bzip2-1.0.6-5
installed = ca-certificates-20160507-1
installed = ca-certificates-cacert-20140824-3
installed = ca-certificates-mozilla-3.24-1
installed = ca-certificates-utils-20160507-1
installed = cairo-1.14.6-1
installed = cairomm-1.12.0-2
installed = cblas-3.6.1-1
installed = chromium-51.0.2704.103-1
installed = cmake-3.5.2-2
installed = colord-1.3.2-2
installed = compositeproto-0.4.2-3
installed = compton-0.1_beta2.5-3
installed = coreutils-8.25-2
installed = cracklib-2.9.6-1
installed = cryptsetup-1.7.2-1
installed = curl-7.49.1-1
installed = damageproto-1.2.1-3
installed = db-5.3.28-3
installed = dbus-1.10.8-1
installed = dbus-glib-0.106-1
installed = dcadec-0.2.0-1
installed = dconf-0.26.0-1
installed = deepin-icon-theme-15.12.27-1
installed = desktop-file-utils-0.22-2
installed = device-mapper-2.02.157-1
installed = dhcpcd-6.11.1-1
installed = dialog-1:1.3_20160424-1
installed = diffutils-3.3-3
installed = dockbarx-0.92-1
installed = dotconf-1.3-4
installed = e2fsprogs-1.42.13-1
installed = elfutils-0.166-1
installed = enchant-1.6.0-8
installed = exempi-2.3.0-1
installed = exo-0.10.7-2
installed = expat-2.1.1-3
installed = faenza-icon-theme-1.3.1-4
installed = fakeroot-1.20.2-1
installed = ffmpeg-1:3.0.2-2
installed = fftw-3.3.4-2
installed = file-5.28-1
installed = file-roller-3.20.2-1
installed = filesystem-2015.09-1
installed = findutils-4.6.0-1
installed = firefox-47.0-2
installed = fixesproto-5.0-3
installed = flac-1.3.1-3
installed = flattr-icon-theme-1.3-2
installed = flex-2.6.0-3
installed = fontconfig-2.12.0-1
installed = fontsproto-2.1.3-1
installed = freetype2-2.6.3-1
installed = fribidi-0.19.7-1
installed = fuse-2.9.7-1
installed = garcon-0.4.0-1
installed = gawk-4.1.3-1
installed = gc-7.4.2-4
installed = gcc-6.1.1-2
installed = gcc-libs-6.1.1-2
installed = gconf-3.2.6-4
installed = gcr-3.20.0-1
installed = gdbm-1.12-2
installed = gdk-pixbuf2-2.34.0-2
installed = gedit-3.20.2-1
installed = geoclue2-2.4.3-1
installed = gettext-0.19.7-1
installed = giflib-5.1.4-1
installed = git-2.9.0-1
installed = glib-networking-2.48.2-1
installed = glib2-2.48.1-1
installed = glibc-2.23-5
installed = glibmm-2.48.1-1
installed = glu-9.0.0-4
installed = gmp-6.1.0-4
installed = gnome-desktop-1:3.20.2-1
installed = gnome-menus2-3.0.1-4
installed = gnupg-2.1.13-1
installed = gnutls-3.4.13-1
installed = gobject-introspection-1.48.0-1
installed = gobject-introspection-runtime-1.48.0-1
installed = gpgme-1.6.0-2
installed = gpm-1.20.7-6
installed = graphite-1:1.3.8-1
installed = grep-2.25-2
installed = groff-1.22.3-6
installed = grub-1:2.02.beta2-6
installed = gsettings-desktop-schemas-3.21.2-1
installed = gsm-1.0.14-1
installed = gspell-1.0.2-1
installed = gst-plugins-base-libs-1.8.2-1
installed = gstreamer-1.8.2-1
installed = gtk-engine-murrine-0.98.2-2
installed = gtk-update-icon-cache-3.20.6-1
installed = gtk2-2.24.30-2
installed = gtk3-3.20.6-1
installed = gtkmm-2.24.4-2
installed = gtksourceview3-3.20.4-1
installed = guile-2.0.11-4
installed = gvfs-1.28.2-1
installed = gvfs-mtp-1.28.2-1
installed = gzip-1.8-2
installed = harfbuzz-1.2.7-1
installed = harfbuzz-icu-1.2.7-1
installed = hdf5-1.10.0-1
installed = hicolor-icon-theme-0.15-1
installed = hspell-1.3-1
installed = hunspell-1.4.1-1
installed = hwids-20160306-1
installed = hyphen-2.8.8-1
installed = iana-etc-20160513-1
installed = icu-57.1-1
installed = imlib2-1.4.9-1
installed = inetutils-1.9.4-2
installed = inputproto-2.3.2-1
installed = intltool-0.51.0-1
installed = iproute2-4.5.0-2
installed = iptables-1.6.0-1
installed = iputils-20160308.0db72a4-1
installed = iso-codes-3.68-1
installed = iw-4.3-1
installed = jansson-2.7-1
installed = jasper-1.900.1-15
installed = jfsutils-1.1.15-4
installed = js17-17.0.0-3
installed = json-c-0.12.1-1
installed = json-glib-1.2.0-1
installed = jsoncpp-1.7.2-1
installed = kbd-2.0.3-1
installed = kbproto-1.0.7-1
installed = keyutils-1.5.9-1
installed = kmod-22-1
installed = krb5-1.13.4-1
installed = lame-3.99.5-3
installed = lapack-3.6.1-1
installed = lcms-1.19-5
installed = lcms2-2.7-1
installed = less-481-2
installed = libaio-0.3.110-1
installed = libarchive-3.2.1-1
installed = libass-0.13.2-1
installed = libassuan-2.4.2-2
installed = libasyncns-0.8-5
installed = libatasmart-0.19-3
installed = libatomic_ops-7.4.4-1
installed = libavc1394-0.5.4-2
installed = libbluray-0.9.2-2
installed = libcanberra-0.30-6
installed = libcap-2.25-1
installed = libcddb-1.3.2-4
installed = libcdio-0.93-3
installed = libcdio-paranoia-10.2+0.93+1-2
installed = libconfig-1.5-3
installed = libcroco-0.6.11-1
installed = libcups-2.1.4-1
installed = libdaemon-0.14-3
installed = libdatrie-0.2.10-1
installed = libdbus-1.10.8-1
installed = libdrm-2.4.68-1
installed = libedit-20150325_3.1-2
installed = libelf-0.166-1
installed = libepoxy-1.3.1-1
installed = libevdev-1.5.2-1
installed = libevent-2.0.22-2
installed = libexif-0.6.21-2
installed = libffi-3.2.1-1
installed = libfontenc-1.1.3-1
installed = libgcrypt-1.7.1-1
installed = libgee-0.18.0-1
installed = libgee06-0.6.8-1
installed = libglade-2.6.4-5
installed = libgpg-error-1.22-1
installed = libgtop-2.34.0-2
installed = libgudev-230-1
installed = libgusb-0.2.9-1
installed = libice-1.0.9-1
installed = libid3tag-0.15.1b-8
installed = libidn-1.32-1
installed = libiec61883-1.2.0-4
installed = libjpeg-turbo-1.5.0-1
installed = libkeybinder2-0.3.0-2
installed = libkeybinder3-0.3.0-4
installed = libksba-1.3.4-1
installed = libldap-2.4.44-2
installed = libmm-glib-1.4.14-1
installed = libmnl-1.0.3-2
installed = libmodplug-0.8.8.5-2
installed = libmpc-1.0.3-2
installed = libmtp-1.1.11-1
installed = libnautilus-extension-3.20.1+17+gf84d431-1
installed = libndp-1.6-1
installed = libnewt-0.52.19-1
installed = libnftnl-1.0.6-1
installed = libnl-3.2.27-1
installed = libnm-glib-1.2.2-1
installed = libnotify-0.7.6-2
installed = libogg-1.3.2-1
installed = libomxil-bellagio-0.9.3-1
installed = libpciaccess-0.13.4-1
installed = libpeas-1.18.0-1
installed = libpgm-5.2.122-2
installed = libpipeline-1.4.1-1
installed = libpng-1.6.23-1
installed = libproxy-0.4.12-2
installed = libpulse-9.0-1
installed = libraw1394-2.1.2-1
installed = librsvg-2:2.40.16-1
installed = libsamplerate-0.1.8-3
installed = libsasl-2.1.26-7
installed = libseccomp-2.3.1-1
installed = libsecret-0.18.5-1
installed = libsigc++-2.8.0-1
installed = libsm-1.2.2-2
installed = libsndfile-1.0.26-1
installed = libsodium-1.0.10-1
installed = libsoup-2.54.1-1
installed = libsoxr-0.1.2-1
installed = libssh-0.7.3-1
installed = libssh2-1.7.0-2
installed = libstemmer-0+337-2
installed = libsystemd-230-5
installed = libtasn1-4.8-2
installed = libteam-1.23-1
installed = libthai-0.1.24-1
installed = libtheora-1.1.1-3
installed = libtiff-4.0.6-2
installed = libtirpc-1.0.1-2
installed = libtool-2.4.6-5
installed = libtracker-sparql-1.8.0-2
installed = libtxc_dxtn-1.0.1-6
installed = libunique-1.1.6-6
installed = libunistring-0.9.6-2
installed = libunwind-1.1-3
installed = libusb-1.0.20-1
installed = libutempter-1.1.6-2
installed = libutil-linux-2.28-1
installed = libva-1.7.1-1
installed = libvdpau-1.1.1-2
installed = libvoikko-4.0.2-1
installed = libvorbis-1.3.5-1
installed = libvpx-1.5.0-4
installed = libwebp-0.5.0-1
installed = libwnck-2.31.0-1
installed = libwnck3-3.20.1-1
installed = libx11-1.6.3-1
installed = libx264-2:148.20160103-1
installed = libxau-1.0.8-2
installed = libxaw-1.0.13-1
installed = libxcb-1.12-1
installed = libxcomposite-0.4.4-2
installed = libxcursor-1.1.14-2
installed = libxdamage-1.1.4-2
installed = libxdmcp-1.1.2-1
installed = libxext-1.3.3-1
installed = libxfce4ui-4.12.1-2
installed = libxfce4util-4.12.1-1
installed = libxfixes-5.0.2-1
installed = libxfont-1.5.1-1
installed = libxft-2.3.2-1
installed = libxi-1.7.6-1
installed = libxinerama-1.1.3-2
installed = libxkbcommon-0.6.1-1
installed = libxkbfile-1.0.9-1
installed = libxklavier-5.4-1
installed = libxml2-2.9.4+0+gbdec218-2
installed = libxmu-1.1.2-1
installed = libxpm-3.5.11-1
installed = libxrandr-1.5.0-1
installed = libxrender-0.9.9-1
installed = libxres-1.0.7-1
installed = libxshmfence-1.2-1
installed = libxslt-1.1.29-1
installed = libxss-1.2.2-2
installed = libxt-1.1.5-1
installed = libxtst-1.2.2-1
installed = libxv-1.0.10-1
installed = libxxf86vm-1.1.4-1
installed = licenses-20140629-1
installed = lightdm-1:1.18.1-2
installed = lightdm-gtk-greeter-1:2.0.1-3
installed = lightdm-gtk-greeter-settings-1.2.0-4
installed = linux-4.6.3-1
installed = linux-api-headers-4.5.5-1
installed = linux-firmware-20160516.80d463b-1
installed = llvm-libs-3.8.0-1
installed = logrotate-3.9.2-1
installed = lvm2-2.02.157-1
installed = lxappearance-0.6.2-1
installed = lxterminal-0.2.0-2
installed = lz4-131-1
installed = lzo-2.09-1
installed = m4-1.4.17-2
installed = make-4.2.1-1
installed = man-db-2.7.5-2
installed = man-pages-4.06-1
installed = mdadm-3.4-1
installed = menumaker-0.99.9-1
installed = mesa-11.2.2-1
installed = mesa-libgl-11.2.2-1
installed = metacity-3.20.1-1
installed = mime-types-9-1
installed = mkinitcpio-19-1
installed = mkinitcpio-busybox-1.24.2-1
installed = mlocate-0.26-5
installed = mobile-broadband-provider-info-20151214-1
installed = mozilla-common-1.4-4
installed = mpfr-3.1.4.p1-1
installed = mtdev-1.1.5-1
installed = nano-2.6.0-1
installed = nautilus-3.20.1+17+gf84d431-1
installed = nautilus-sendto-3.8.4-1
installed = ncurses-6.0-4
installed = netcdf-4.4.1rc1-1
installed = netctl-1.12-2
installed = nettle-3.2-2
installed = network-manager-applet-1.2.2-1
installed = networkmanager-1.2.2-1
installed = networkmanager-dispatcher-ntpd-1.0-6
installed = nitrogen-1.5.2-4
installed = nm-connection-editor-1.2.2-1
installed = npth-1.2-1
installed = nspr-4.12-1
installed = nss-3.24-1
installed = ntp-4.2.8.p8-1
installed = numix-themes-2.5.1.r233.a6be634-1
installed = obconf-2.0.4-4
installed = oblogout-0.2-17
installed = openbox-3.6.1-3
installed = opencore-amr-0.1.3-2
installed = openjpeg-1.5.2-1
installed = openresolv-3.8.1-1
installed = openssl-1.0.2.h-1
installed = opus-1.1.2-1
installed = orc-0.4.25-2
installed = os-prober-1.71-1
installed = p11-kit-0.23.2-1
installed = package-query-1.8-1
installed = pacman-5.0.1-4
installed = pacman-mirrorlist-20160614-1
installed = pam-1.2.1-3
installed = pambase-20130928-1
installed = pango-1.40.1-1
installed = pangomm-2.40.0-1
installed = patch-2.7.5-1
installed = pciutils-3.5.1-1
installed = pcmciautils-018-7
installed = pcre-8.39-1
installed = perl-5.24.0-1
installed = perl-error-0.17024-1
installed = perl-file-basedir-0.07-1
installed = perl-ipc-system-simple-1.25-1
installed = perl-uri-1.71-1
installed = perl-xml-parser-2.44-3
installed = pinentry-0.9.7-2
installed = pixman-0.34.0-1
installed = pkg-config-0.29.1-1
installed = polkit-0.113-4
installed = popt-1.16-8
installed = procps-ng-3.3.11-2
installed = protobuf-2.6.1-2
installed = psmisc-22.21-3
installed = pulseaudio-9.0-1
installed = pulseaudio-alsa-2-3
installed = pygobject-devel-3.20.0-2
installed = pygobject2-devel-2.28.6-12
installed = pygtk-2.24.0-6
installed = pyrex-0.9.9-4
installed = python-3.5.1-2
installed = python-beaker-1.8.0-1
installed = python-dbus-common-1.2.4-1
installed = python-gobject-3.20.0-2
installed = python-mako-1.0.4-1
installed = python-markupsafe-0.23-3
installed = python-packaging-16.7-1
installed = python-pyparsing-2.1.4-1
installed = python-setuptools-1:23.1.0-1
installed = python-six-1.10.0-1
installed = python-xdg-0.25-3
installed = python2-2.7.11-3
installed = python2-cairo-1.10.0-2
installed = python2-dbus-1.2.4-1
installed = python2-distutils-extra-2.39-1
installed = python2-gconf-2.28.1-9
installed = python2-gobject2-2.28.6-12
installed = python2-keybinder2-0.3.0-2
installed = python2-numpy-1.11.0-1
installed = python2-pillow-3.2.0-1
installed = python2-wnck-2.32.0-15
installed = python2-xdg-0.25-3
installed = python2-xlib-0.15rc1-7
installed = randrproto-1.5.0-1
installed = readline-6.3.008-4
installed = recordproto-1.14.2-2
installed = reflector-2015.12-2
installed = reiserfsprogs-3.6.24-1
installed = renderproto-0.11.1-3
installed = rest-0.8.0-1
installed = rsync-3.1.2-1
installed = rtkit-0.11-5
installed = s-nail-14.8.9-1
installed = sbc-1.3-1
installed = schroedinger-1.0.11-3
installed = scrnsaverproto-1.2.2-2
installed = sdl-1.2.15-7
installed = sed-4.2.2-4
installed = shadow-4.2.1-3
installed = shared-mime-info-1.6-2
installed = slang-2.3.0-1
installed = slingscold-1.2.1-1
installed = snappy-1.1.3-2
installed = sound-theme-freedesktop-0.8-2
installed = speech-dispatcher-0.8.4-2
installed = speex-1.2rc2-1
installed = speexdsp-1.2rc3-2
installed = sqlite-3.13.0-1
installed = startup-notification-0.12-4
installed = sudo-1.8.16-1
installed = synapse-0.2.99.2-2
installed = sysfsutils-2.1.0-9
installed = systemd-230-5
installed = systemd-sysvcompat-230-5
installed = tar-1.29-1
installed = tdb-1.3.8-1
installed = telepathy-glib-0.24.1-1
installed = texinfo-6.1-4
installed = thin-provisioning-tools-0.6.1-2
installed = tint2-0.12.11-1
installed = transset-df-6-5
installed = ttf-dejavu-2.35-1
installed = tzdata-2016e-1
installed = udisks2-2.1.7-1
installed = unzip-6.0-12
installed = usbutils-008-1
installed = util-linux-2.28-1
installed = v4l-utils-1.10.1-1
installed = vala-0.32.1-1
installed = vi-1:070224-2
installed = vid.stab-1.1-1
installed = videoproto-2.3.3-1
installed = vte-0.28.2-7
installed = vte-common-0.44.2-1
installed = vte3-0.44.2-1
installed = wayland-1.11.0-1
installed = wayland-protocols-1.4-1
installed = webkit2gtk-2.12.3-1
installed = webrtc-audio-processing-0.3-1
installed = which-2.21-2
installed = wpa_supplicant-1:2.5-3
installed = x265-1.9-1
installed = xapian-core-1:1.2.23-1
installed = xbitmaps-1.1.1-3
installed = xcb-proto-1.12-2
installed = xcb-util-0.4.0-1
installed = xcompmgr-1.1.7-1
installed = xdg-user-dirs-0.15-4
installed = xdg-utils-1.1.1-2
installed = xextproto-7.3.0-1
installed = xf86-input-evdev-2.10.3-1
installed = xf86-input-synaptics-1.8.99.1-1
installed = xf86-video-ati-1:7.7.0-1
installed = xf86vidmodeproto-2.3.1-3
installed = xfce4-dockbarx-plugin-git-47.988c916-1
installed = xfce4-panel-4.12.0-2
installed = xfce4-whiskermenu-plugin-1.5.3-2
installed = xfconf-4.12.0-4
installed = xfsprogs-4.5.0-1
installed = xineramaproto-1.2.1-3
installed = xkeyboard-config-2.18-1
installed = xorg-bdftopcf-1.0.5-1
installed = xorg-font-util-1.3.1-1
installed = xorg-font-utils-7.6-4
installed = xorg-fonts-alias-1.0.3-1
installed = xorg-fonts-encodings-1.0.4-4
installed = xorg-fonts-misc-1.0.3-4
installed = xorg-iceauth-1.0.7-1
installed = xorg-luit-1.1.1-2
installed = xorg-mkfontdir-1.0.7-2
installed = xorg-mkfontscale-1.1.2-1
installed = xorg-server-1.18.3-2
installed = xorg-server-common-1.18.3-2
installed = xorg-server-utils-7.6-4
installed = xorg-sessreg-1.1.0-1
installed = xorg-setxkbmap-1.3.1-1
installed = xorg-twm-1.0.9-1
installed = xorg-xauth-1.0.9-1
installed = xorg-xbacklight-1.2.1-1
installed = xorg-xcmsdb-1.0.5-1
installed = xorg-xgamma-1.0.6-1
installed = xorg-xhost-1.0.7-1
installed = xorg-xinit-1.3.4-4
installed = xorg-xinput-1.6.2-1
installed = xorg-xkbcomp-1.3.1-1
installed = xorg-xmodmap-1.0.9-1
installed = xorg-xrandr-1.5.0-1
installed = xorg-xrdb-1.1.0-2
installed = xorg-xrefresh-1.0.5-1
installed = xorg-xset-1.2.3-1
installed = xorg-xsetroot-1.1.1-2
installed = xproto-7.0.29-1
installed = xterm-325-1
installed = xvidcore-1.3.4-1
installed = xz-5.2.2-1
installed = yajl-2.1.0-1
installed = yaourt-1.8.1-1
installed = zeitgeist-0.9.16-1
installed = zenity-3.20.0-1
installed = zeromq-4.1.4-1
installed = zip-3.0-7
installed = zlib-1.2.8-4

Notice it lists the home directory of ajjames31, and all the extra packages james has installed, (over 500).
Heres the same program, built from a clean chroot with ~100 packages in it.
For details, (see ref. 2)
Code: Select all
builddir = /build
pkgbuild_sha256sum = a58ed2f638d1e42d0d1399571687250d6fa0a389ac4a589b45ba32f4c76c59f7
buildenv = !distcc
buildenv = color
buildenv = !ccache
buildenv = check
buildenv = !sign
options = strip
options = docs
options = !libtool
options = !staticlibs
options = emptydirs
options = zipman
options = purge
options = !optipng
options = !upx
options = !debug
installed = acl-2.2.52-3
installed = archlinux-keyring-20170611-1
installed = attr-2.4.47-2
installed = autoconf-2.69-4
installed = automake-1.15.1-1
installed = bash-4.4.012-2
installed = binutils-2.28.0-3
installed = bison-3.0.4-2
installed = bzip2-1.0.6-6
installed = ca-certificates-20170307-1
installed = ca-certificates-cacert-20140824-4
installed = ca-certificates-mozilla-3.31-3
installed = ca-certificates-utils-20170307-1
installed = coreutils-8.27-1
installed = cracklib-2.9.6-1
installed = curl-7.54.1-1
installed = db-5.3.28-3
installed = diffutils-3.6-1
installed = e2fsprogs-1.43.4-1
installed = expat-2.2.1-1
installed = fakeroot-1.21-2
installed = file-5.31-1
installed = filesystem-2017.03-2
installed = findutils-4.6.0-2
installed = flex-2.6.4-1
installed = gawk-4.1.4-2
installed = gc-7.6.0-1
installed = gcc-7.1.1-3
installed = gcc-libs-7.1.1-3
installed = gdbm-1.13-1
installed = gettext-0.19.8.1-2
installed = glib2-2.52.3-1
installed = glibc-2.25-5
installed = gmp-6.1.2-1
installed = gnupg-2.1.21-3
installed = gnutls-3.5.14-1
installed = gpgme-1.9.0-3
installed = grep-3.1-1
installed = groff-1.22.3-7
installed = guile-2.2.2-1
installed = gzip-1.8-2
installed = iana-etc-20170512-1
installed = icu-59.1-1
installed = keyutils-1.5.10-1
installed = krb5-1.15.1-1
installed = less-487-1
installed = libarchive-3.3.1-5
installed = libassuan-2.4.3-1
installed = libatomic_ops-7.4.6-1
installed = libcap-2.25-1
installed = libffi-3.2.1-2
installed = libgcrypt-1.7.8-1
installed = libgpg-error-1.27-1
installed = libidn-1.33-1
installed = libksba-1.3.4-2
installed = libldap-2.4.44-5
installed = libmpc-1.0.3-2
installed = libnghttp2-1.23.1-1
installed = libpsl-0.17.0-2
installed = libsasl-2.1.26-11
installed = libsecret-0.18.5+14+g9980655-1
installed = libssh2-1.8.0-2
installed = libsystemd-233.75-3
installed = libtasn1-4.12-1
installed = libtirpc-1.0.2-1
installed = libtool-2.4.6-8
installed = libunistring-0.9.7-1
installed = libutil-linux-2.29.2-2
installed = linux-api-headers-4.10.1-1
installed = lz4-1:1.7.5-1
installed = m4-1.4.18-1
installed = make-4.2.1-2
installed = mpfr-3.1.5.p2-1
installed = ncurses-6.0+20170527-1
installed = nettle-3.3-1
installed = npth-1.5-1
installed = openssl-1.1.0.f-1
installed = p11-kit-0.23.7-1
installed = package-query-1.8-2
installed = pacman-5.0.2-1
installed = pacman-mirrorlist-20170628-1
installed = pam-1.3.0-1
installed = pambase-20130928-1
installed = patch-2.7.5-1
installed = pcre-8.40-1
installed = perl-5.26.0-1
installed = pinentry-1.0.0-1
installed = pkg-config-0.29.2-1
installed = readline-7.0.003-1
installed = sed-4.4-1
installed = shadow-4.4-3
installed = sqlite-3.19.3-1
installed = sudo-1.8.20.p2-1
installed = tar-1.29-2
installed = texinfo-6.4-1
installed = tzdata-2017b-1
installed = util-linux-2.29.2-2
installed = which-2.21-2
installed = xz-5.2.3-1
installed = yajl-2.1.0-1
installed = zlib-1:1.2.11-1

Building your packages from a clean chroot will benefit you greatly, now and especially as you grow.
If you have any questions about this, I'd be glad to have the chance to help with this great distro!
dros

References:
1) https://wiki.archlinux.org/index.php/De ... ean_Chroot
2) https://github.com/graysky2/clean-chroot-manager
User avatar
dros
 
Posts: 4
Joined: Fri Jul 07, 2017 11:59 pm

Re: Package Building on Archlabs.

PostPosted by erikdubois » Mon Jul 10, 2017 5:42 pm

Thanks for your info.

Question : How can I retrieve this information you are displaying?
Living to learn, learning to live.
Linux fits well in my life's motto.
More info on http://erikdubois.be
Archlabs support articles are on https://goo.gl/AaYI0b
Archlabs support youtube channel is on https://goo.gl/Lovquv
User avatar
erikdubois
Site Admin
Site Admin
 
Posts: 333
Joined: Sun Mar 05, 2017 5:42 am
Location: Belgium

Re: Package Building on Archlabs.

PostPosted by dros » Tue Jul 11, 2017 12:12 am

Go into the built package tar file, and look at build info :
yaourt-1.8.1-1-any.pkg.tar.xz --> Extract it--> view .BUILDINFO
User avatar
dros
 
Posts: 4
Joined: Fri Jul 07, 2017 11:59 pm

Re: Package Building on Archlabs.

PostPosted by erikdubois » Tue Jul 11, 2017 3:02 am

that i did not do.
thanks
Living to learn, learning to live.
Linux fits well in my life's motto.
More info on http://erikdubois.be
Archlabs support articles are on https://goo.gl/AaYI0b
Archlabs support youtube channel is on https://goo.gl/Lovquv
User avatar
erikdubois
Site Admin
Site Admin
 
Posts: 333
Joined: Sun Mar 05, 2017 5:42 am
Location: Belgium


Return to Suggestions and Improvements

Who is online

Users browsing this forum: No registered users and 0 guests

cron